The Movie Database Support

Hi, I'm new to using this db and still figuring things out. When I tried to run a discover for movies with runtime less than 60mins, the result I get is returning some movies with more than 60mins runtime.

Result includes movies "Hereditary", "K-PAX", "Dances with Wolves" and more which have runtime of 127mins, 120mins, 181mins respectively.

Is there something wrong with my query?

8 replies (on page 1 of 1)

Jump to last post


this was already discussed here. Your query is fine, but:

  • Hereditary had incorrectly set runtime to 2 minutes in lt-LT translation
  • K-PAX had incorrectly set runtime to 2 minutes in sr-RS translation
  • Dances with Wolves had incorrectly set runtime to 3 minutes in es-MX translation

I've corrected all above mentioned records, but unless @travisbell change how discover method with "&with_runtime=" parameter works (e.g. by taking into account query language), it may happen.

Alright, thanks for clarifying!

After looking through the API forum it seems that it's a known bug that discover/movies could return some inaccurate runtimes.

Guess I'll just figure out a way to get around this.

Just for extra clarification, there's two separate issues being discussed/mentioned here.

First is how discover now indexes runtimes, which is by looking at all of the available values. This is the correct way to do it, and won't be changing.

Second is to do with a bug that I know about with regards to querying runtimes with discover. That bug is being tracked here, which you can follow/vote for if you wish. It will be getting fixed in the next few weeks.

I believe the runtime query issues have been fixed, please let me know if you see it not working.


Hi Travis,

Thanks for the update!

I ran the same query again as above and although the result did show some movies that are less than 60 mins, it did include those that are over that runtime as well.

For example, the first result shows Cars which actually has a runtime of 117 mins.

Other results that came up were Deadpool (108 mins), Logan (137 mins), The Lion King (89mins), The Fate of the Furious (196 mins), Forrest Gump (142 mins), Harry Potter and the Prisoner of Azkaban (141 mins), Ted 2(115 mins), Goosebumps 2: Haunted Halloween (90 mins)..

This was only the first page but I suppose this issue might appear for the other pages as well unfortunately.


It's the same issue again:

  • The Cars had es-MX translation with runtime 1 minute
  • Deadpool had id-ID translation with runtime 1 minute
  • Logan had sh-TW translation with runtime 2 minutes

and so on...

I've corrected the 3 above mentioned movies, but I'm not able to check them all. If I understand it correctly, this is intended behavior of the API, so it is on us to correct all wrong runtimes...

I've removed over 800 invalid movie runtimes, so discover with "&with_runtime.lte" should return more relevant results now.

Thanks @talestalker. I have a pretty simple way to help catch bad inputs that I’ll end up rolling out in the next few weeks. That will also improve things.


s focus the search bar
p open profile menu
esc close an open window
? open keyboard shortcut window

On media pages

b go back (or to parent when applicable)
e go to edit page

On TV season pages

(right arrow) go to next season
(left arrow) go to previous season

On TV episode pages

(right arrow) go to next episode
(left arrow) go to previous episode

On all image pages

a open add image window

On all edit pages

t open translation selector
ctrl+ s submit form

On discussion pages

n create new discussion
w toggle watching status
p toggle public/private
c toggle close/open
a open activity
r reply to discussion
l go to last reply
ctrl+ enter submit your message
(right arrow) next page
(left arrow) previous page