The Movie Database Support

For about a month now, I have been having a weird kind of error when querying via the discover method. I have been getting error status_code 11.

When I run something like this, it works well https://api.themoviedb.org/3/discover/movie?api_key=xxxxxxxxxx&primary_release_date.gte=YYYY-MM-DD&primary_release_date.lte=YYYY-MM-DD&with_genres=28,12|16&include_adult=false&page=1

But change the 'with_genres=28|12,16' to 'with_genres=28|12,16' and everything crashes. Been like this for a while now

2 replies (on page 1 of 1)

Jump to last post

Hi Ladna Meke,

Thanks for the report. I've added a new ticket and will look at this soon.

Cheers.

Hey Ladna,

I've pushed a fix for this so that it doesn't error anymore but it should be noted that a nested expression like that is not currently supported. The parser is a little too simple to take a combined OR/AND condition right now. Right now we only support a single condition expressed at a time.

Cheers.

Can't find a movie or TV show? Login to create it.

Global

s focus the search bar
p open profile menu
esc close an open window
? open keyboard shortcut window

On media pages

b go back (or to parent when applicable)
e go to edit page

On TV season pages

(right arrow) go to next season
(left arrow) go to previous season

On TV episode pages

(right arrow) go to next episode
(left arrow) go to previous episode

On all image pages

a open add image window

On all edit pages

t open translation selector
ctrl+ s submit form

On discussion pages

n create new discussion
w toggle watching status
p toggle public/private
c toggle close/open
a open activity
r reply to discussion
l go to last reply
ctrl+ enter submit your message
(right arrow) next page
(left arrow) previous page

Want to rate or add this item to a list?

Login