The Movie Database Support

Hi,

Since a little month when you post an url on facebook you don't have a preview but just "page not found". Very annoying to share with friends. Is it volunteer to keep your data or there is a technical problem ?

https://ibb.co/Fx2Xmcf

Thanks.

10 replies (on page 1 of 1)

Jump to last post

Hmmm... I don't have any clue why that would be happening. It's a valid URL, as you can see by going there:

https://www.themoviedb.org/movie/429203-the-old-man-and-the-gun?language=fr-FR

We don't do any user agent filtering or anything like that on the website, so I really have no clue what would cause that...

Recently see that the url has changed :
https://www.themoviedb.org/tv/62286/fr become :
https://www.themoviedb.org/tv/62286-fear-the-walking-dead?language=fr-FR

These 2 url still working but none of them make any preview on facebook anymore.

So probably a modification on Facebook side... :/

I will try to ask them.

Thanks for your answer.

@schmurtz said:

Recently see that the url has changed :
https://www.themoviedb.org/tv/62286/fr become :
https://www.themoviedb.org/tv/62286-fear-the-walking-dead?language=fr-FR

We've always redirected the /fr (or any other valid ISO tag) to the full URL. That's not new. It's been this way for years, so something else has changed... thinking

ah OK I never paid attention to this... So OK, no correlation with the problem ;)

Hi, I'm having the same problem, many users reported this issue to me, it seems Facebook it's not loading data correctly.

I've ran the Facebook debugger tool which seems to get a 404 response. Example for Star Wars movie: https://developers.facebook.com/tools/debug/sharing/?q=https%3A%2F%2Fwww.themoviedb.org%2Fmovie%2F11-star-wars

Maybe it's due to a domain DDOS protection or anything similar which recognizes Facebook's crawler as a robot and denies the access.

Any clue? Other social network crawlers seem to be working fine

Best regards

I just pushed a fix for this. Let me know how it looks now. Facebook caches these requests for some amount of time. On some of the links I checked I had to click the "Scrape Again" link for it to pick up updates.

Thank you very much for fix that! I can confirm it's working now

Regards

@travisbell said:

I just pushed a fix for this. Let me know how it looks now. Facebook caches these requests for some amount of time. On some of the links I checked I had to click the "Scrape Again" link for it to pick up updates.

Yes ! It works again, thank you !

One more question about facebook previews : you explain to me that I can add /fr to the end of the url to get it in a specific language. This trick don't work in facebook previews : the preview still in english if I add "/fr" or "?language=fr-FR". After a click on the url posted on facebook I arrive on the french page of tmdb so the url is good but the preview generated is always in english.

Preview imdb french

Hi @schmurtz I have fixed this in the upcoming v5 release. The URL's will start using their properly localized data once it's public. Thanks.

That's awesome, thanks for the support ! Looking forward this new releas !

Can't find a movie or TV show? Login to create it.

Global

s focus the search bar
p open profile menu
esc close an open window
? open keyboard shortcut window

On media pages

b go back (or to parent when applicable)
e go to edit page

On TV season pages

(right arrow) go to next season
(left arrow) go to previous season

On TV episode pages

(right arrow) go to next episode
(left arrow) go to previous episode

On all image pages

a open add image window

On all edit pages

t open translation selector
ctrl+ s submit form

On discussion pages

n create new discussion
w toggle watching status
p toggle public/private
c toggle close/open
a open activity
r reply to discussion
l go to last reply
ctrl+ enter submit your message
(right arrow) next page
(left arrow) previous page

Want to rate or add this item to a list?

Login