The Movie Database Support

I am developing an application in Android Studio and get JSONObject from URL. Until recently, everything worked well. Unfortunately, now I can’t get JSONObject by using device with Android 4.1 or 4.4. But if I use a device with Android 7.1 everything works well. Please help me understand this problem.

5 replies (on page 1 of 1)

Jump to last post

I think they're down

There was another blip with our search service, what's the error you're seeing?

I was seeing 504, but we're back up! :)

The program see the JSONObject from URL as null. Test on the emulator and on a real device. A device with Android 4.1 has stopped seeing JSONObject. This has happened recently. Before that, everything worked.

P.S. this is not due to a temporary failure and error 504

Your server has changed the protocol TLS. Now server is setup with TLS 1.2. Android 4.x devices don't support that.

Global

s focus the search bar
p open profile menu
esc close an open window
? open keyboard shortcut window

On media pages

b go back (or to parent when applicable)
e go to edit page

On TV season pages

(right arrow) go to next season
(left arrow) go to previous season

On TV episode pages

(right arrow) go to next episode
(left arrow) go to previous episode

On all image pages

a open add image window

On all edit pages

t open translation selector
ctrl+ s submit form

On discussion pages

n create new discussion
w toggle watching status
p toggle public/private
c toggle close/open
a open activity
r reply to discussion
l go to last reply
ctrl+ enter submit your message
(right arrow) next page
(left arrow) previous page